Skype 2.7 + iMac G3 != true

Nix, det funkar inte. Jag försökte installera senaste versionen av Skype (2.7.0.330) på min gamla iMac G3 (Mac OSX 10.4), startade programmet efter det installerats och inget händer, flera gånger, jag kikar i applikationsloggen för att finna “Link (dyld) error: incompatible cpu-subtype”, tack som fan Skype! Jag gav mig ut och sökte efter tidigare versioner